Eintragsdetails ansehen

IDProjektKategorieSichtbarkeitZuletzt aktualisiert
0002476EresseaNACH/ROUTEöffentlich2018-08-21 22:29
ReporterHalimaBearbeitung durchEnno 
PrioritätnormalAuswirkungkleinerer FehlerReproduzierbarnicht getestet
Status erledigtLösungkeine Änderung notwendig 
Produktversion3.16.6 
Zielversion3.18Behoben in Version 
Zusammenfassung0002476: Einheit transportiert nicht
Beschreibung

Hi Enno,
nicht allzu dramatisch, die Schmiede steht, aber die Arbeiter wurden nicht transportiert

Befehl lautete:
EINHEIT vrtn; Fuhrmann [1,0$]
Transportiere 8vjn ni58 dt98 a6ev weyr
Nach NW W

Die Einheiten hatten "Fahre" gesetzt, die erstgenannte Einheit 8vjn wurde auch transportiert, die weiteren jedoch nicht
(jede der weiteren Einheiten produzierte die Fehlermeldung "'FAHRE vrtn' - Die Einheit transportiert uns nicht."

Weiß nicht warum, habe auch in der wiki unter "Fahre" nachgeschaut, dort ist "TRANSPORTIERE 311 777 ; Lasse 311 und 777 mitfahren" als Beispiel angeführt, dem bin ich ja gefolgt.

Tnx für nachschauen

Martin

ParteiHali
SpielE2
Report1089

Notizen / Dateien

Julius

Julius

2018-08-19 10:40

Reporter   ~0008033

Ich denke dass Beispiel bei FAHRE ist falsch. Bei TRANSPORTIERE steht nichts von optionalen zusätzlichen Einheiten, die angegeben werden können (https://wiki.eressea.de/index.php/TRANSPORTIERE).

Ich gebe dir jede Einheit die transportiert werden soll einen eigenen TRANSPORTIERE Befehl. Das passt auch zum beobachteten Verhalten, dass nur die erste gelistete Einheit transportiert wurde.

Als Feature Wunsch wäre dass aber nett, wenn es ginge mehrere Einheitennummern bei einem TRANSPORTIERE Befehl anzugeben.

Julius

Julius

2018-08-19 10:42

Reporter   ~0008034

*Ich gebe bei jeder Einheit...

Xolgrim

Xolgrim

2018-08-19 15:31

Entwickler   ~0008040

Bei Transportiere steht nichts von mehreren Nummern die man angeben kann. Wie Halima aber richtig geschrieben hat, steht es in dem Beispiel unter https://wiki.eressea.de/index.php/FAHRE explizit als angegebenes Beispiel mit:
"TRANSPORTIERE 311 777 ; Lasse 311 und 777 mitfahren"
Vorausgesetzt Halima hat alle Befehle korrekt gegeben, liegt hier also definitv ein Fehler von. Entweder im Code oder in der Anleitung.

Enno

Enno

2018-08-21 22:29

Administrator   ~0008042

Kein Bug. TRANSPORTIERE kann nur eine Einheit als Argument bekommen, um mehrere Einheiten zu transportieren, muss man den Befehl mehrfach geben.

Eintrags-Historie

Änderungsdatum Benutzername Feld Änderung
2018-08-19 05:27 Halima Neuer Eintrag
2018-08-19 10:40 Julius Notiz hinzugefügt: 0008033
2018-08-19 10:42 Julius Notiz hinzugefügt: 0008034
2018-08-19 13:35 Enno Produktversion => 3.16.6
2018-08-19 13:35 Enno Zielversion => 3.18
2018-08-19 15:31 Xolgrim Notiz hinzugefügt: 0008040
2018-08-21 22:29 Enno Notiz hinzugefügt: 0008042
2018-08-21 22:29 Enno Bearbeitung durch => Enno
2018-08-21 22:29 Enno Status neu => erledigt
2018-08-21 22:29 Enno Lösung offen => keine Änderung notwendig